Subject: [lojban] Re: nai in UI (was: BPFK phpbb)

From: Robin Lee Powell <[email-masked]>
Date: Tue, 29 Apr 2003 17:03:05 -0700

On Tue, Apr 29, 2003 at 07:58:33PM -0400, John Cowan wrote:
> Robin Lee Powell scripsit:
> 
> > For the same reason you can't say "pu bai klama": LALR(1). If
> > you haven't gotten used to doing "pu je bai klama", you either
> > are new, or aren't interested in doing proper formal lojban
> > anyways.
> 
> Actually "pu bai klama" is fine: it's "pu [ku] bai klama". The
> rules about tenses are really pretty nugatory: if you violate
> them, the parser will just insert ku's anyhow.

So that would be a bug in jbofi'e, then?

mi pu bai klama
--------------------
SYNTAX ERROR IN TEXT
--------------------
Misparsed token :
klama [BRIVLA] (line 1, col 11)
Latest successfully parsed tokens :
bai [BAI] (line 1, col 7)
MARKER : PRIVATE_START_BAI
pu [PU] (line 1, col 4)
mi [KOhA3] (line 1, col 1)
--------------------

> Furthermore, the tense part of the grammar is not at all LALR(1).

Oh. What is it, then?

-Robin

-- 
http://www.digitalkingdom.org/~rlpowell/ *** I'm a *male* Robin.
.i le pamoi velru'e zo'u crepu le plibu taxfu
.i le remoi velru'e zo'u mo .i le cimoi velru'e zo'u ba'e prali .uisai
http://www.lojban.org/ *** to sa'a cu'u lei pibyta'u cridrnoma toi

---

From: Robin Lee Powell <[email-masked]>
Date: Tue, 29 Apr 2003 17:03:05 -0700

mi pu bai klama
--------------------
SYNTAX ERROR IN TEXT
--------------------
Misparsed token :

Oh. What is it, then?

-Robin