Subject: Re: [lojban] Re: Some ideas/questions (long)

From: John Cowan <[email-masked]>
Date: Tue, 6 May 2003 23:23:05 -0400

[email-masked] scripsit:

> Apologies for hijacking this thread, but upon hearing about this use of the
> "error" token, I am starting to feel somewhat uncomfortable. Specifically, I
> fear that using such strange hacks will make it harder to explain (and
> grasp) intuitively when certain words can be elided, without referring to a
> specific 1970's parsing technology.

Yacc error handling is used to supply elidable terminators. "cu" is 
optional in the grammar, not supplied by error recovery (although using it
does change which terminators may be elided, of course).

-- 
I am expressing my opinion. When my John Cowan
honorable and gallant friend is called, [email-masked]
he will express his opinion. This is http://www.ccil.org/~cowan
the process which we call Debate. --Winston Churchill

---

From: John Cowan <[email-masked]>
Date: Tue, 6 May 2003 23:23:05 -0400